Sensor Thresholds are not being set

I am working on activating the alert system for my sensors. I am currently trying to get all of the upper/lower levels of thresholds working. In the config file (see image 1), I have my params section with all the events Or’d together, I turned on the assert/deassert mask bits, and I have threshold values. However, looking at my ipmitool sensor readout (see image 2), it shows ‘na’ for all 6 threshold values. I confirm this using clia in the shelf manager, which has commands for getting thresholds; none are retrieved. When I try to use the command to set a threshold, it will not let me.

Ideally, the thresholds are set upon uploading the firmware. Is there something I am missing that will actually have these values I put in the config file be set for the sensor?

image 1

image 2

Hi @mtepper,

I ran some test locally and I can see the thresholds. The only way to not see them it so instantiate the same sensor without any threshold and then, upload a new version with it but without changing the nonVolatileParams value from <nonVolatileParams forced="false" /> to <nonVolatileParams forced="true" />

Could it be your issue?


Issue has been solved by setting the right value to DiscreteRdMask node.