Recovering the IPMC without IPMI


I have 2 unusable IPMCs, for 2 different reasons. One was bugged by the IPMI hpm rollback command, the other one by a mistake in code. Both do not answer to IPMI commands. How to recover them?




You can recover them using the JTAG interface (process detailled here: However, I tried the command but I was not able to reproduce your issues: flashing a code with an error (the automatic rollback worked well) and a second one with a manual rollback that worked as well. Did you do something special? Did you well activate the version? What was the bug you had in your code?


Thanks. Automatic rollback always worked well, as I mentioned in an email long ago, but the rollback command bricked my IPMC. I don’t think I did something special with the setup.

I believe the firmware was activated, since the same version of the firmware was running in the IPMC at that moment. Unless you meant something different.

The other IPMC is not related to the rollback problem. I just got trapped inside of a loop, and it seems that the IPMC has no protection for that (watchdog, or similar)