IPMB analyser tool doesn't work

Dear IPMC support,

I tried to play on the devkit with the ipmb_sniffer tool but it seems that it does not work, no bytes exchanged on the I2C lines are captured.

Here are the outputs of ipmb_sniffer from the command line:

pi@lapp-pi06:~ $ ipmb_sniffer -t 60 -f ~/ipmba.pcap -p ipmba
[Info] Open port IPMB-A [0]
[Info] Start saving to /home/pi/ipmba.pcap for 60 seconds
[Info] Saved 0 bytes
pi@lapp-pi06:~ $ ipmb_sniffer -t 60 -f ~/ipmbb.pcap -p ipmbb
[Info] Open port IPMB-B [1]
[Info] Start saving to /home/pi/ipmbb.pcap for 60 seconds
[Info] Saved 0 bytes



Hello Fatih,

Stefan, Ralf and I have tried to get ipmb-sniffer to work but failed. We have noticed that the Python code (maybe you can confirm that your code has the same “feature”) contains the line


The variable “port”, which is set to “impba” or “ipmbb” in your examples, is never used and ipmb-sniffer always accesses ipmbl (because of the hard-wired “2”). We have also tried to capture data from ipmbl but with no success.

Please let us know how crucial this tool is for you.



Hello Markus,

I implement the CERN-IPMC module on a simple ATCA board, So, I could do without it, instead I can use the ipmb_traced tool provided in the Shelf Manager. In my opinion, it will be more crucial for people who implement the CERN-IPMC module on an ATCA carrier if they want to capture data on the IPMB-L bus for debugging.